Understanding through Discussion


Welcome! You are not logged in. [ Login ]
EvC Forum active members: 80 (8960 total)
25 online now:
PaulK, vimesey (2 members, 23 visitors)
Newest Member: Mikee
Post Volume: Total: 869,215 Year: 963/23,288 Month: 963/1,851 Week: 86/321 Day: 1/47 Hour: 0/0


Thread  Details

Email This Thread
Newer Topic | Older Topic
  
Author Topic:   dBoard Version 1.0 is Released!
Ben!
Member (Idle past 2003 days)
Posts: 1154
From: San Diego, CA
Joined: 10-14-2004


Message 76 of 198 (171976)
12-28-2004 7:43 PM
Reply to: Message 1 by Admin
12-25-2004 5:06 PM


No paging in search results
Maybe this is expected behavior, but I just wanted to double-check.

The search results page does NOT page results. I thought it might page results according to my preferences. For me, I'm not really interested in searching through 100 results--just the top 25.

Anyhoo.


This message is a reply to:
 Message 1 by Admin, posted 12-25-2004 5:06 PM Admin has not yet responded

  
Ben!
Member (Idle past 2003 days)
Posts: 1154
From: San Diego, CA
Joined: 10-14-2004


Message 77 of 198 (171982)
12-28-2004 7:53 PM
Reply to: Message 1 by Admin
12-25-2004 5:06 PM


Missing thread in search results
I've been searching for about 20 minutes for a subject that I KNOW I responded to with some content...

(found it by manually paging my posts)...

www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=14&t=546&m=1 -->www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=14&t=546&m=1">http://www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=14&t=546&m=1

I can't get this thread using the search function. There's many really concrete terms in it:

dopamine
Sapolsky
Stanford University
Damasio

Can you check this out?


This message is a reply to:
 Message 1 by Admin, posted 12-25-2004 5:06 PM Admin has not yet responded

  
Ben!
Member (Idle past 2003 days)
Posts: 1154
From: San Diego, CA
Joined: 10-14-2004


Message 78 of 198 (171983)
12-28-2004 7:54 PM
Reply to: Message 1 by Admin
12-25-2004 5:06 PM


No bookmarks on URLs for
Easy fix, REALLY ANNOYING tho...

Run the search function, and you get some message results. But if you click the link to the message, you get the right page, but since there's no bookmark on the URL to the specific message, you have to page down to find the proper message.

:(


This message is a reply to:
 Message 1 by Admin, posted 12-25-2004 5:06 PM Admin has responded

Replies to this message:
 Message 109 by Admin, posted 12-30-2004 10:23 PM Ben! has not yet responded

  
Ben!
Member (Idle past 2003 days)
Posts: 1154
From: San Diego, CA
Joined: 10-14-2004


Message 79 of 198 (171984)
12-28-2004 7:58 PM
Reply to: Message 1 by Admin
12-25-2004 5:06 PM


500 ISE when updating avatar
The avatar was updated though.

I was worried I couldn't keep my plan to update my avatar every 100 posts. Whew! :rolleyes:


This message is a reply to:
 Message 1 by Admin, posted 12-25-2004 5:06 PM Admin has not yet responded

  
Ben!
Member (Idle past 2003 days)
Posts: 1154
From: San Diego, CA
Joined: 10-14-2004


Message 80 of 198 (172001)
12-28-2004 9:05 PM
Reply to: Message 1 by Admin
12-25-2004 5:06 PM


Bug with editing date / time
As found by Moose here,

The DATE of an edit is written DIRECTLY into the HTML, rather than being inserted based on their locale and format choices (i.e. profile).

The LEAST that should be changed is to add the timezone / locale to the date/time inserted in the HTML

The BEST is if you could parameterize this date as well, so that it can be calculated based on user profile settings.


This message is a reply to:
 Message 1 by Admin, posted 12-25-2004 5:06 PM Admin has responded

Replies to this message:
 Message 81 by Admin, posted 12-28-2004 10:45 PM Ben! has responded

  
Admin
Director
Posts: 12655
From: EvC Forum
Joined: 06-14-2002
Member Rating: 3.3


Message 81 of 198 (172009)
12-28-2004 10:45 PM
Reply to: Message 80 by Ben!
12-28-2004 9:05 PM


Re: Bug with editing date / time
Reply to messages 76 through 80:

76: The search results are planned to eventually page following the board and user settings.

77: Among a number of reasons for the extensive rewrite is that the search database is too slow and too easily corrupted. Failure to find search terms is because of corrupted databases. The evolution forum finally accumulated so many messages that the search database couldn't be built from scratch, which is necessary when the database becomes corrupted, because of server processor time limits. I'm in the process of redesigning the search database. I'm planning to use Perl's DB_File unless/until someone suggests something better.

78: I'm getting search results with bookmarks to the message in the file. If you give me an example search that has this problem I'll check it out.

80: I had considered both the alternatives you mentioned. I agree that just adding timezone info to the edit comment is a "least" scenario, but it's the one I have time for.

To all who are finding and reporting bugs/problems/dislikes: this is invaluable, thank you very much!


--Percy
EvC Forum Director

This message is a reply to:
 Message 80 by Ben!, posted 12-28-2004 9:05 PM Ben! has responded

Replies to this message:
 Message 84 by Ben!, posted 12-29-2004 8:40 AM Admin has responded

  
Admin
Director
Posts: 12655
From: EvC Forum
Joined: 06-14-2002
Member Rating: 3.3


Message 82 of 198 (172060)
12-29-2004 7:27 AM


Reply Notification Fix
Those who have selected reply notification in their profile might have noticed that the name of the thread was *not* being included in the body of the email. This has been fixed.

This message has been edited by Admin, 12-29-2004 09:09 AM


--Percy
EvC Forum Director

  
Ben!
Member (Idle past 2003 days)
Posts: 1154
From: San Diego, CA
Joined: 10-14-2004


Message 83 of 198 (172067)
12-29-2004 8:34 AM
Reply to: Message 1 by Admin
12-25-2004 5:06 PM


Visible email in profile, but non-visible email in message
Parasomnium has an email address exposed in the profile page, but it is not available as a link in her message (see below URL). Unless she just changed the setting of whether to expose it (which I know can cause this behavior)... something is awry here. Since the message is pretty new, I don't think it's due to a change in the user's profile.

Parasomnium's Profile
Parasomnium's message

Can you check this out? I wanted to email this poster, but I wasn't sure if the poster had wanted to display or hide the aforementioned email address. So I'll wait for your reply to decide.


This message is a reply to:
 Message 1 by Admin, posted 12-25-2004 5:06 PM Admin has responded

Replies to this message:
 Message 85 by Admin, posted 12-29-2004 9:56 AM Ben! has not yet responded
 Message 121 by Lammy, posted 01-03-2005 2:41 PM Ben! has not yet responded

  
Ben!
Member (Idle past 2003 days)
Posts: 1154
From: San Diego, CA
Joined: 10-14-2004


Message 84 of 198 (172068)
12-29-2004 8:40 AM
Reply to: Message 81 by Admin
12-28-2004 10:45 PM


Re: Bug with editing date / time
78: I'm not even getting bookmarks on the message links when I view the recent messages that I've written (i.e. click on my own name).

This message is a reply to:
 Message 81 by Admin, posted 12-28-2004 10:45 PM Admin has responded

Replies to this message:
 Message 87 by Admin, posted 12-29-2004 2:22 PM Ben! has not yet responded

  
Admin
Director
Posts: 12655
From: EvC Forum
Joined: 06-14-2002
Member Rating: 3.3


Message 85 of 198 (172081)
12-29-2004 9:56 AM
Reply to: Message 83 by Ben!
12-29-2004 8:34 AM


Re: Visible email in profile, but non-visible email in message
Ben writes:

Can you check this out? I wanted to email this poster, but I wasn't sure if the poster had wanted to display or hide the aforementioned email address. So I'll wait for your reply to decide.

You have Director status during this period of testing - you see all, know all. If you logout, you'll no longer be able to see the email addresses of members who want them private.


--Percy
EvC Forum Director

This message is a reply to:
 Message 83 by Ben!, posted 12-29-2004 8:34 AM Ben! has not yet responded

Replies to this message:
 Message 86 by Adminnemooseus, posted 12-29-2004 11:19 AM Admin has not yet responded

  
Adminnemooseus
Director
Posts: 3912
Joined: 09-26-2002


Message 86 of 198 (172092)
12-29-2004 11:19 AM
Reply to: Message 85 by Admin
12-29-2004 9:56 AM


Re: Visible email in profile, but non-visible email in message
I checked Ben's examples - Right now the e-mail address is private in both locations. My guess is that the profile page was updated (removing the e-mail address) and the page had then not yet been updated.

In the old software, and apparently in the new also, the e-mail addresses can be hidden at both the message pages and at the profile pages. This is the case even if the viewer has some sort of admin status, up to and including Director. At least that's the case for me.

Admins, however, do have other accesses to all member e-mail address's, even those hidden on the public pages. I have on occassion used that special access to try to recruite a new admin person.

Adminnemooseus


This message is a reply to:
 Message 85 by Admin, posted 12-29-2004 9:56 AM Admin has not yet responded

  
Admin
Director
Posts: 12655
From: EvC Forum
Joined: 06-14-2002
Member Rating: 3.3


Message 87 of 198 (172107)
12-29-2004 2:22 PM
Reply to: Message 84 by Ben!
12-29-2004 8:40 AM


Re: Bug with editing date / time
Ben writes:

78: I'm not even getting bookmarks on the message links when I view the recent messages that I've written (i.e. click on my own name).

Bookmarks for search results and member message lists should now be present.


--Percy
EvC Forum Director

This message is a reply to:
 Message 84 by Ben!, posted 12-29-2004 8:40 AM Ben! has not yet responded

  
Admin
Director
Posts: 12655
From: EvC Forum
Joined: 06-14-2002
Member Rating: 3.3


Message 88 of 198 (172112)
12-29-2004 2:56 PM
Reply to: Message 26 by Ben!
12-26-2004 4:04 AM


Re: Old links in posts
You described a problem where a link pointed to a page of a thread that didn't exist. The thread has only one message:

http://http://www.evcforum.net/cgi-bin/dm.cgi?action=page&f=16&t=3&m=1

If this is due to a bug, I'm not able to reproduce any circumstances that reproduce it. I wonder if it is possibly due to user error - perhaps the original thread or forum number was incorrect.

Anyway, I'm taking this one off my list until I get another report of it happening.


--Percy
EvC Forum Director

This message is a reply to:
 Message 26 by Ben!, posted 12-26-2004 4:04 AM Ben! has not yet responded

  
RAZD
Member
Posts: 20460
From: the other end of the sidewalk
Joined: 03-14-2004
Member Rating: 3.6


Message 89 of 198 (172186)
12-29-2004 10:36 PM
Reply to: Message 1 by Admin
12-25-2004 5:06 PM


glitches
I just found that I am not getting notices of replies in either my e-mail or the post listing
(www.evcforum.net/cgi-bin/Threads.cgi?action=tml&mn=RAZD -->www.evcforum.net/cgi-bin/Threads.cgi?action=tml&mn=RAZD">http://www.evcforum.net/cgi-bin/Threads.cgi?action=tml&mn=RAZD)

when I went to one of my threads -- What is the evolutionary advantage to religion?
(www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=29&t=11&m=1 -->www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=29&t=11&m=1">http://www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=29&t=11&m=1)
there were many replies that I should have been notified of but haven't.

also -- could you increase the contrast on the buttons at the end of the posts? perhaps red text? they are hard to read for my old myopic (color deprived?) eyes.


This message is a reply to:
 Message 1 by Admin, posted 12-25-2004 5:06 PM Admin has responded

Replies to this message:
 Message 90 by Admin, posted 12-30-2004 7:04 AM RAZD has responded

  
Admin
Director
Posts: 12655
From: EvC Forum
Joined: 06-14-2002
Member Rating: 3.3


Message 90 of 198 (172223)
12-30-2004 7:04 AM
Reply to: Message 89 by RAZD
12-29-2004 10:36 PM


Re: glitches
I haven't changed the email notification code, and email notifications are working for my Admin account - I was notified of your reply, for example. Your profile seems to be properly set up for email notification.

Everyone: is anyone else out there experiencing a problem with email notification?

About the "Replies Await" column in your topic index, the code currently only detects if there's a reply to your *last* message. There have been many requests to fix this, and I plan to do so, but there's no schedule at the current time.


--Percy
EvC Forum Director

This message is a reply to:
 Message 89 by RAZD, posted 12-29-2004 10:36 PM RAZD has responded

Replies to this message:
 Message 103 by RAZD, posted 12-30-2004 9:51 PM Admin has responded

  
Newer Topic | Older Topic
Jump to:


Copyright 2001-2018 by EvC Forum, All Rights Reserved

™ Version 4.0 Beta
Innovative software from Qwixotic © 2020