Understanding through Discussion


Welcome! You are not logged in. [ Login ]
EvC Forum active members: 65 (9073 total)
65 online now:
AZPaul3, jar, kjsimons, nwr, PaulK, Phat, Tangle, Tanypteryx (8 members, 57 visitors)
Newest Member: MidwestPaul
Post Volume: Total: 893,289 Year: 4,401/6,534 Month: 615/900 Week: 139/182 Day: 19/27 Hour: 1/0

Announcements: Security Update Released


Thread  Details

Email This Thread
Newer Topic | Older Topic
  
Author Topic:   dBoard 3.0 Beta Release Today
Admin
Director
Posts: 12793
From: EvC Forum
Joined: 06-14-2002
Member Rating: 2.0


Message 61 of 426 (514829)
07-13-2009 8:01 AM
Reply to: Message 57 by Blue Jay
07-13-2009 12:48 AM


Re: HTML Characters
Hi Bluejay, and everyone else who noticed the funny character problem:

This is an easy problem to fix, but I need a table of what corresponds to what. For example, ’ seems to be the single quote, but what are the rest? If someone can give me a complete or at least fairly complete table I'll make the funny characters go away.


--Percy
EvC Forum Director

This message is a reply to:
 Message 57 by Blue Jay, posted 07-13-2009 12:48 AM Blue Jay has taken no action

Replies to this message:
 Message 62 by RAZD, posted 07-13-2009 10:21 PM Admin has seen this message
 Message 63 by RAZD, posted 07-13-2009 10:23 PM Admin has replied
 Message 64 by Dr Jack, posted 07-14-2009 5:49 AM Admin has seen this message

RAZD
Member (Idle past 644 days)
Posts: 20714
From: the other end of the sidewalk
Joined: 03-14-2004


Message 62 of 426 (514910)
07-13-2009 10:21 PM
Reply to: Message 61 by Admin
07-13-2009 8:01 AM


Re: HTML Characters
some are dashes, here are some others

Ken Miller’s website,

It’s “irreducible” and it evolved.

Reimer, Paula J. et al, "INTCAL04 Terrestrial Radiocarbon Age Calibration, 0–26 CAL KYR BP" Radiocarbon, Volume 46, Issue 3,

Siegenthaler, Urs et al. "Stable Carbon Cycle–Climate Relationship During the Late Pleistocene" Science 3

Stable Carbon Cycle–Climate Relationship During


This message is a reply to:
 Message 61 by Admin, posted 07-13-2009 8:01 AM Admin has seen this message

RAZD
Member (Idle past 644 days)
Posts: 20714
From: the other end of the sidewalk
Joined: 03-14-2004


Message 63 of 426 (514911)
07-13-2009 10:23 PM
Reply to: Message 61 by Admin
07-13-2009 8:01 AM


links to old threads
The links to old threads seems to be messed up. I keep getting

http://www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=10&t=221&m=1

instead of several old links and in response to google site search


This message is a reply to:
 Message 61 by Admin, posted 07-13-2009 8:01 AM Admin has replied

Replies to this message:
 Message 68 by Admin, posted 07-18-2009 11:54 AM RAZD has replied

Dr Jack
Member (Idle past 1343 days)
Posts: 3507
From: Leicester, England
Joined: 07-14-2003


Message 64 of 426 (514930)
07-14-2009 5:49 AM
Reply to: Message 61 by Admin
07-13-2009 8:01 AM


Utf-8
Aren't they UTF-8 codes?

You can convert them here by hand, but I'd have expected you to be able to source a nice Perl gidgit to do it for you fairly easily.

A quick google located this and this related to character encoding problems in Perl (dBoard is written in Perl, isn't it?).

Edited by Mr Jack, : Links added


This message is a reply to:
 Message 61 by Admin, posted 07-13-2009 8:01 AM Admin has seen this message

Taz
Member (Idle past 2530 days)
Posts: 5069
From: Zerus
Joined: 07-18-2006


Message 65 of 426 (515354)
07-17-2009 12:16 PM
Reply to: Message 53 by Admin
07-11-2009 8:20 PM


Admin writes:

The "Replies" column now indicates that there is at least one response to one of your messages in the thread that you haven't yet replied to.


You of all people should know not all replies to your posts require replies from you. Before this annoying feature, I kept track of my own posts and replies. The "yes" buttom was only there for me to make a quick glance to see if anyone replied to my lastest post. Now, that function is completely useless. If someone replied to a post I made in the same thread but 2 years ago and I already determined it wasn't necessary to reply back, I'd still see a "yes". Can you imagine how annoying this is?

I've been trying to adapt to the new board. I really have. But I still can't find myself liking it one bit. I'm having a lot of difficulties navigating through posts. Not to mention I can't jump to the last page of a particular thread entering it first...


This message is a reply to:
 Message 53 by Admin, posted 07-11-2009 8:20 PM Admin has replied

Replies to this message:
 Message 66 by Admin, posted 07-18-2009 7:32 AM Taz has seen this message

Admin
Director
Posts: 12793
From: EvC Forum
Joined: 06-14-2002
Member Rating: 2.0


Message 66 of 426 (515449)
07-18-2009 7:32 AM
Reply to: Message 65 by Taz
07-17-2009 12:16 PM


Hi Taz,

Feedback is appreciated, so please keep it coming. Feedback about board behavior to threads like this is valuable for me because I'm trying to create the best board software out there, and it helps you too, because I will change features that aren't working out.

So don't worry too much, it's going to get better. As I've mentioned before, I was forced to release the new software early because the number of messages, over a half million, was becoming unwieldy. Some features are not yet in their final form, and the way indications of a reply work is one of those features.

In the case of the "Yes" reply indicator, I'm planning to turn this into two links:

  • The "Yes" will become a link you can click on to turn it into "No". Clicking on it will mark all replies to your messages that you haven't responded to to "noted". Clicking on "No" will change the "noted" back to "no".

  • A new link, probably just another blue arrow for now since I don't yet have icon help, will take you to the oldest message that you haven't responded to.

In the meantime, you can still click on the "Taz posts only" link and then quickly go through your messages changing all the "no" indicators to "noted".

To me this seems like one of those features where developers have to try out several variations before finding the right one, and it is also possible that the feature may have to be discarded. Where I work we have a special observation room with one way glass so we can observe users of various levels of expertise interacting with our software. Unfortunately, EvC Forum doesn't have these kinds of resources.

The page links could be making a comeback soon, but I have some questions for people. Is it just a link to the top of the last page people want, and they don't need a link to all the other pages? Or do people want the complete list of page links? Or would a "Jump to page" link be okay?

In the meantime, there's still the "last messaage" link, which although it takes you to the bottom of the last page instead of the top, at least you're on the right page and can scroll up.


--Percy
EvC Forum Director

This message is a reply to:
 Message 65 by Taz, posted 07-17-2009 12:16 PM Taz has seen this message

Replies to this message:
 Message 67 by RAZD, posted 07-18-2009 11:37 AM Admin has seen this message

RAZD
Member (Idle past 644 days)
Posts: 20714
From: the other end of the sidewalk
Joined: 03-14-2004


Message 67 of 426 (515497)
07-18-2009 11:37 AM
Reply to: Message 66 by Admin
07-18-2009 7:32 AM


feedback and back again to set forth on new requests ...
Hi Percy,

The issue of old "yes" posts is one I'll take the heat for, it being one of my requests.

In the meantime, you can still click on the "Taz posts only" link and then quickly go through your messages changing all the "no" indicators to "noted".

I just went through the last 6 months of my posts and did this. As you can appreciate, my volume of posting makes this a rather cumbersome task, and unfortunately there are still many old threads that carry a "yes" for one or two messages.

Perhaps it just needs a few tweaks - say a link from the "yes" to an index of just the unreplied posts on that thread, with an option to mark all as "noted" and perhaps a link to mark all posts older than 3, 6, 9, 12 (bullets) months automatically as "noted"?

It would also be helpful if all unreplied messages on archived threads were automatically converted - but this would necessitate a distinction between thread closed permanently (archived) from those closed for off-topic behavior.

One of my problems is that I have a couple of people (Straggler, AlphaOmegaKid, JohnFulton, etc) who make multiple replies to my posts, so now I need to go back and mark all the multiples as "noted", and this has given me a couple of ideas for further tweaks (and you thought you had some free time ...):

(1) Multiple post reply: have a bullet for each reply one of your posts that you can pick to include in the "this is a reply to" (and with each one listed in the "Text of message you're replying to:" box).

(2) Have the system note when a second reply is made, by advising the person that they have already replied and can edit the previous reply, particularly if it's status is still "no" answer.

(3) Also have a note whether a message has been edited since your reply has been made.

(4) Similar to replies to yourself, with the reply automatically marked as "noted" ...

I also find searching for closed threads to be difficult, as the search engine only seems to look at open threads, and google is still not converted. I wonder if other search engines don't use indexing and could be used - I have some I can test.

Or do people want the complete list of page links?

I liked the complete list to track the history of a sub-thread, particularly back to the initial subtopic. What if you had something like the "Taz posts only" for subtitles? This could show up on the subtitle line as "posts for this subtitle only" or something similar.

I'm getting used to the new system, so once we are fully implemented I can see the dust settling. What's that old saying about adversity making you stronger?

Enjoy.

Edited by RAZD, : )


we are limited in our ability to understand
by our ability to understand
Rebel American Zen Deist
... to learn ... to think ... to live ... to laugh ...
to share.


• • • Join the effort to solve medical problems, AIDS/HIV, Cancer and more with Team EvC! (click) • • •

This message is a reply to:
 Message 66 by Admin, posted 07-18-2009 7:32 AM Admin has seen this message

Admin
Director
Posts: 12793
From: EvC Forum
Joined: 06-14-2002
Member Rating: 2.0


Message 68 of 426 (515501)
07-18-2009 11:54 AM
Reply to: Message 63 by RAZD
07-13-2009 10:23 PM


Re: links to old threads
The old-style links threads should now work. This fix only covers old-style links that you've bookmarked. Please let me know if you have any problems.

The old-style links in messages were not modified properly during the update, and these still do not work. I am fixing this now and will let you know when I am done.


--Percy
EvC Forum Director

This message is a reply to:
 Message 63 by RAZD, posted 07-13-2009 10:23 PM RAZD has replied

Replies to this message:
 Message 69 by RAZD, posted 07-18-2009 1:29 PM Admin has seen this message

RAZD
Member (Idle past 644 days)
Posts: 20714
From: the other end of the sidewalk
Joined: 03-14-2004


Message 69 of 426 (515516)
07-18-2009 1:29 PM
Reply to: Message 68 by Admin
07-18-2009 11:54 AM


Re: links to old threads
Yep, so far it's working. Woot!

Another thing I noticed when perusing my old threads to annotate the unreplied replies, was that many of the pictures don't seem to show up from my site - any correlation?


This message is a reply to:
 Message 68 by Admin, posted 07-18-2009 11:54 AM Admin has seen this message

Admin
Director
Posts: 12793
From: EvC Forum
Joined: 06-14-2002
Member Rating: 2.0


Message 70 of 426 (515523)
07-18-2009 2:44 PM
Reply to: Message 50 by Adminnemooseus
07-11-2009 6:26 PM


Re: Signature problem - Merged member - Also, link to message problem
Hi Moose,

Most broken message links in old messages should now be fixed. There are still some broken links left, but I think I've fixed all the most important types. Please let me know if you find any more broken link types that you think should be fixed.


--Percy
EvC Forum Director

This message is a reply to:
 Message 50 by Adminnemooseus, posted 07-11-2009 6:26 PM Adminnemooseus has taken no action

Replies to this message:
 Message 71 by RAZD, posted 07-18-2009 3:02 PM Admin has replied

RAZD
Member (Idle past 644 days)
Posts: 20714
From: the other end of the sidewalk
Joined: 03-14-2004


Message 71 of 426 (515524)
07-18-2009 3:02 PM
Reply to: Message 70 by Admin
07-18-2009 2:44 PM


Re: Signature problem - Merged member - Also, link to message problem
I found an interesting problem on one post:

Message 33 the links at the end of the post are

quote:
References
1. The bacterial flagella motor. PubMed on-line article from Adv Microb Physiol. 1999;41:291-337.
2. Timetable: Development of the Propeller. On line article.
3. History & Design of Propeller. On line article.

And when I look at the coding for the first one it is:

quote:
<a href="http://www.ncbi.nlm.nih.gov/entrez/query.fcgi?cmd=Retrieve&...amp;l ist_uids =1050084 8&...amp;dopt=Citation">The bacterial flagella motor</a>. PubMed on-line article from Adv Microb Physiol. 1999;41:291-337.

I have no idea what happened to the url.


Is there something I need to do to resolve the image issue?

with <p align="center"><img border="0" src="http://razd.evcforum.net/Pictures/flagellum.jpg" height="300"></p> I get

The picture link seems to be changed by the removal of "evcforum.net" from "razd.evcforum.net" and it works when I insert this:

Can you fix, or do I need to manually edit every post ...

Thanks.

Edited by Admin, : Shorten very long line.


we are limited in our ability to understand
by our ability to understand
Rebel American Zen Deist
... to learn ... to think ... to live ... to laugh ...
to share.


• • • Join the effort to solve medical problems, AIDS/HIV, Cancer and more with Team EvC! (click) • • •

This message is a reply to:
 Message 70 by Admin, posted 07-18-2009 2:44 PM Admin has replied

Replies to this message:
 Message 72 by Admin, posted 07-18-2009 3:14 PM RAZD has replied

Admin
Director
Posts: 12793
From: EvC Forum
Joined: 06-14-2002
Member Rating: 2.0


Message 72 of 426 (515526)
07-18-2009 3:14 PM
Reply to: Message 71 by RAZD
07-18-2009 3:02 PM


Re: Signature problem - Merged member - Also, link to message problem
I can fix these links everywhere fairly easily, but it looks like you fixed the links in the referenced message already. Can you provide me a link to another message that has the same issues? I want to see the problems in their original form so I can make sure I fix them properly.


--Percy
EvC Forum Director

This message is a reply to:
 Message 71 by RAZD, posted 07-18-2009 3:02 PM RAZD has replied

Replies to this message:
 Message 73 by RAZD, posted 07-18-2009 3:21 PM Admin has replied

RAZD
Member (Idle past 644 days)
Posts: 20714
From: the other end of the sidewalk
Joined: 03-14-2004


Message 73 of 426 (515528)
07-18-2009 3:21 PM
Reply to: Message 72 by Admin
07-18-2009 3:14 PM


Re: Signature problem - Merged member - Also, link to message problem
try "age correlations"

http://www.evcforum.net/cgi-bin/dm.cgi?action=msg&f=25&t=2601&m=1

Message 4 - I can't edit the closed threads.


This message is a reply to:
 Message 72 by Admin, posted 07-18-2009 3:14 PM Admin has replied

Replies to this message:
 Message 74 by Admin, posted 07-18-2009 4:14 PM RAZD has seen this message

Admin
Director
Posts: 12793
From: EvC Forum
Joined: 06-14-2002
Member Rating: 2.0


Message 74 of 426 (515529)
07-18-2009 4:14 PM
Reply to: Message 73 by RAZD
07-18-2009 3:21 PM


Re: Signature problem - Merged member - Also, link to message problem
I fixed the simple things, for instance to make the pictures work. The more complicated problems, for instance the "Smith, Paul" links, follow a varying pattern, and crafting the required text substitution would take too long. A correct version of the link is present, though amidst corrupted versions. Best that can be done at this time.

Let me know if you find more of the easy type of problem.


--Percy
EvC Forum Director

This message is a reply to:
 Message 73 by RAZD, posted 07-18-2009 3:21 PM RAZD has seen this message

Minnemooseus
Member
Posts: 3879
From: Duluth, Minnesota, U.S. (West end of Lake Superior)
Joined: 11-11-2001
Member Rating: 2.7


Message 75 of 426 (515779)
07-21-2009 4:40 AM


Problems at the All Forums page
http://www.evcforum.net/cgi-bin/dBoard.cgi

Everthing seems to be in order, except seeing "Forum Name Not Available" instead of the forum names, and also a lot of "Thread Name Not Available".

Moose


Replies to this message:
 Message 76 by Admin, posted 07-21-2009 9:23 AM Minnemooseus has taken no action
 Message 79 by Admin, posted 07-21-2009 8:27 PM Minnemooseus has taken no action

Newer Topic | Older Topic
Jump to:


Copyright 2001-2018 by EvC Forum, All Rights Reserved

™ Version 4.1
Innovative software from Qwixotic © 2022